Tutorials and guides contributions

Moderator: amosbatto

By taysouf
#785431
Hello guys i hope you are doing fine , i am new with process maker 3.0.1 ... i want to make a connection between processMaker and Alfresco Community via alfresco trigger on ProcessMaker , i want to upload a file from process maker to alfresco repository , i tried to fill the form of the trigger
(url server file name source .....) , but still not working , it keeps telling me file not found hope you help me guys i really appreciate it .
Thanks in advance .
Cordially TAYANE Soufiane .
User avatar
By amosbatto
#785512
I don't have Alfresco installed to try it, but I see that the description of the first parameter is wrong in the trigger wizard. See:
http://wiki.processmaker.com/index.php/ ... dDoc.28.29

The first parameter is the URL where the Alfresco server is located, so you should enter something like:
http://www.example.com/alfresco
or:
http://localhost:8500/alfresco
By taysouf
#785539
i tried what u told me , but it keeps telling me file not found , i want an example of the value of these 2 parameters,
"$fileSource" and " $docType" , thank you a lot for your answer and your time .
User avatar
By amosbatto
#785595
For $fileSource, try something like "@C:\Users\Bob\MyDocuments\myphoto.png" where the file is located that you want to upload. I think that you have to add the @ to get it to upload. If that doesn't work, then try "C:\Users\Bob\MyDocuments\myphoto.png" .

For the $docType, that is probably defined inside Alfresco. Sorry, I don't have Alfresco installed, but you should check the Alfresco API, because all of this is probably explained there.
Dell Printer Error State

You can fix the error by checking the network conn[…]

I have a problem where tasks on leaving the pause […]

Starting subprocess

I have a grid with multiple rows and it has a colu[…]

It is not a single field which is causing this is[…]