Le Forum de la Communauté française - Forum for French speakers

Moderators: amosbatto, mjaenvar

By dsiumalis
#779873
Bonjour à tous,

Je commence à utiliser Processmaker depuis quelques mois. Prochainement je commence l'étape de production .

J'ai un souci avec les caractères spéciaux é, à, ô, ...

Voici une part d'un mail que je dois envoyer
Bonjour.

La date de déclaration des taxes sociales pour la société ....
Le code HTML est sous cette forme
Code: Select all
<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
</head>
<body>
<p><span lang="FR">Bonjour.<o:p></o:p></span></p>
<p>La date de d&eacute;claration des taxes sociales pour la soci&eacute;t&eacute; ....
Et le résultat est sous cette forme :
Bonjour.

La date de déclaration des taxes sociales pour la société ....
J'ai ajouté la langue française aux langues de ProcessMaker.
J'utilise la version 2.5

Avez vous rencontrez ce Problème ?

Merci pour votre aide
#780584
Oui j'ai le même soucis et il s'agit d'après moi d'un bug dans processmaker qui se produit lors de l'envoi de notifications et précisemment lorsque les html est parsé.

Cela pose un problème lorsque le template est en UTF8. Dans ce cas le contenu du mail est systématiquement ré-encodé en UTF8 alors qu'il n'en n a pas besoin.

J'ai apporté la modification suivante au fichier “/opt/processmaker/gulliver/system/class.g.php” dans la méthode “unhtmlentities” :
Code: Select all
public function unhtmlentities ($string) {
        $trans_tbl = get_html_translation_table( HTML_ENTITIES );
// Ligne ajoutée ; added line
       $is_utf8 = (strtolower(mb_detect_encoding($string)) == "utf-8");
        foreach ($trans_tbl as $k => $v) {
                // Ligne revue ; updated line
//$ttr[$v] = utf8_encode( $k );
            $ttr[$v] = ($is_utf8) ? $k : utf8_encode( $k );
            $ttr[$v] = $k ;
        }
        return strtr( $string, $ttr );
}
By alainb
#781005
JE sais qu'il est un peu tard mais pour d'autre qui se aurait le même problème j'ai remarqué que les variables utilise dans les formulaires n'était pas converties.

Présentement nous avons des gens Anglophones et francophone, j'ai donc créé un templade (canvas) du message et mis les textes dans des variables.

Ainsi avant d'envoyer un message, j'appele un trigger qui met le bon texte dans la variable selon la langue de la personne qui receveras le courriel.

Cela m'évite aussi d'avoir deux documents à maintenir.
#794979
kelamri wrote:Oui j'ai le même soucis et il s'agit d'après moi d'un bug dans processmaker qui se produit lors de l'envoi de notifications et précisemment lorsque les html est parsé.

Cela pose un problème lorsque le template est en UTF8. Dans ce cas le contenu du mail est systématiquement ré-encodé en UTF8 mutuelles TNS alors qu'il n'en n a pas besoin.

J'ai apporté la modification suivante au fichier “/opt/processmaker/gulliver/system/class.g.php” dans la méthode “unhtmlentities” :

public function unhtmlentities ($string) {
$trans_tbl = get_html_translation_table( HTML_ENTITIES );
// Ligne ajoutée ; added line
$is_utf8 = (strtolower(mb_detect_encoding($string)) == "utf-8");
foreach ($trans_tbl as $k => $v) {
// Ligne revue ; updated line
//$ttr[$v] = utf8_encode( $k );
$ttr[$v] = ($is_utf8) ? $k : utf8_encode( $k );
$ttr[$v] = $k ;
}
return strtr( $string, $ttr );
}
J'ai essayé d'introduire la commande, mais je n'arrive pas à y accéder. Je ne sais pas ce qui se passe.

ProcessMaker hanging after i change item in proces[…]

I want all users to be able to start a process/cas[…]

I dont think so because the database is on the sa[…]

I don't have MSSQL installed to test this, but I i[…]