Windows XAMPP installation

Ein Diskussionsforum für unsere deutschsprechende Gemeinschaft.

Moderators: amosbatto, schuerstedt

reamon
Posts: 4
Joined: Tue Mar 24, 2009 5:40 am

Windows XAMPP installation

Unread postby reamon » Tue Mar 24, 2009 5:54 am

hallo zusammen,

ich hab pm unter windows mit xampp installiert und es "läuft" auch soweit.
der ordner befindet sich auf "C:\processmaker\workflow"
die pmos.conf sieht wie folgt aus:

Code: Select all

# Please change the ip address with your server ip address and
# the ServerName with you own subdomains.
NameVirtualHost 192.168.5.71
#processmaker virtual host
<VirtualHost 192.168.5.71>
ServerName "192.168.5.71"
DocumentRoot "C:\processmaker\workflow\public_html"
DirectoryIndex index.html index.php
<Directory "C:\processmaker\workflow\public_html">
AddDefaultCharset UTF-8
AllowOverRide none
Options FollowSymlinks
Order allow,deny
Allow from all
RewriteEngine on
RewriteRule ^.*/(.*)$ sysGeneric.php [NC,L]
# ExpiresActive On
# ExpiresDefault "access plus 1 day"
# ExpiresByType image/gif "access plus 1 day"
# ExpiresByType image/png "access plus 1 day"
# ExpiresByType image/jpg "access plus 1 day"
# ExpiresByType text/css "access plus 1 day"
# ExpiresByType text/javascript "access plus 1 day"
# AddOutputFilterByType DEFLATE text/html
</Directory>
</VirtualHost>


login funktioniert soweit.

allerdings bekomm ich sobald ich einen menüpunkt (in diesem beispiel wars der punkt "vorg" folgenden fehler:

Code: Select all

Notice: XML error in C:/processmaker/workflow/engine/xmlform/cases/cases_ListTodo.xml: Invalid character at line 30 in C:\processmaker\gulliver\system\class.xmlDocument.php on line 262

Notice: XML error in C:/processmaker/workflow/engine/xmlform/cases/cases_List.xml: Invalid character at line 24 in C:\processmaker\gulliver\system\class.xmlDocument.php on line 262


ein weiterer fehler tritt auf, wenn ich einen neuen prozess anlegen möchte. es erscheint das fenster mit dem gitternetz mit der laufenden "flashuhr".
sobald ich z.b. auf "eingabedokumente" klicke wird eine seite mit folgender fehlermeldung angezeigt:
404 Not Found
Your browser (or proxy) sent a request that this server could not understand.

Possible reasons:
Your link is broken. This may occur when you receive a link via email, but your client software adds line breaks, thus distorting long URLs.

The page you requested is no longer active.

There is a typographic error in the link, in case you entered the URL into the browser's address toolbar.


url
referer http://192.168.5.71/sysworkflow/de/gree ... 0097972534


soweit die fehler. jetzt bin ich mal gespannt, was im deutschen forum so geht :D .

vielen dank schonmal.

grüße,
reamon

schuerstedt
Posts: 34
Joined: Fri Aug 22, 2008 4:19 am

Re: Windows XAMPP installation

Unread postby schuerstedt » Tue Mar 24, 2009 6:03 am

Hallo Reamon,

ich nehme mal, dass du die neueste Version einsetzt, oder? Ich hab die selber noch nicht getestet. Bisher sind die XAMP Installationen immer ohne irgendwelche Nacharbeit/Konfiguration gelaufen. Ich schau da mal rein...

Hast du evtl. irgendeine Firewall etc. im Einsatz?
*************************************************************************************
http://www.processmaker.de für eine deutschsprachige Processmaker Community

reamon
Posts: 4
Joined: Tue Mar 24, 2009 5:40 am

Re: Windows XAMPP installation

Unread postby reamon » Tue Mar 24, 2009 6:16 am

hallo schuerstedt,

vielen dank für die schnelle reaktion.
ich hab die datei "pmos-1.2-2261.tar.gz" heruntergeladen. denke, dass das die aktuellste version ist - oder?
nö, eine firewall läuft auf dem rechner nicht. ich teste das gerade auf unserem "intranetserver"

schuerstedt
Posts: 34
Joined: Fri Aug 22, 2008 4:19 am

Re: Windows XAMPP installation

Unread postby schuerstedt » Tue Mar 24, 2009 6:30 am

Teste doch mal mit der fertigen Installation für Windows (ProcessMaker-1.2-2261-windows-installer.exe). Dort wird ja ein fertiger XAMP Server installiert, konfiguriert etc. Vielleicht gibt das die entsprechenden Ideen, wie man es von Hand konfigurieren müsste. Hab ich auf Windows nämlich auch noch nie gemacht...
*************************************************************************************
http://www.processmaker.de für eine deutschsprachige Processmaker Community

reamon
Posts: 4
Joined: Tue Mar 24, 2009 5:40 am

Re: Windows XAMPP installation

Unread postby reamon » Tue Mar 24, 2009 7:39 am

würd ich ja schon machen, aber was passiert mit meiner bereits existierenden xamp installation?
will mir nicht das system kaputt machen :D

schuerstedt
Posts: 34
Joined: Fri Aug 22, 2008 4:19 am

Re: Windows XAMPP installation

Unread postby schuerstedt » Tue Mar 24, 2009 8:33 am

Solange du das in ein eigenes Verzeichnis packst, eigentlich gar nichts, wenn du andere Ports für Apache und MySQL definierst. Ich hab so schon mehrere Versionen von PM parallel laufen gehabt. Kostet halt Ressourcen, da dann mehrere Apache gleichzeitig laufen.
*************************************************************************************
http://www.processmaker.de für eine deutschsprachige Processmaker Community

reamon
Posts: 4
Joined: Tue Mar 24, 2009 5:40 am

Re: Windows XAMPP installation

Unread postby reamon » Tue Mar 24, 2009 11:55 am

das hat leider nur einen teilerfolg ergeben.
nun kamen bei z.b. bedingungen die xml-fehler. werds nochmal auf einem blanken rechner versuchen.

virnie
Posts: 5
Joined: Wed Apr 08, 2009 10:44 am
Country: United States of America
Location: Buenos Aires AR

Re: Windows XAMPP installation

Unread postby virnie » Wed Apr 15, 2009 1:08 pm

Can someone translate the possible solution of this thread in English or maybe in Spanish?. That would be a good help for me. Thanks!

pmUser2000
Site Admin
Posts: 460
Joined: Fri Aug 31, 2007 6:48 pm

Re: Windows XAMPP installation

Unread postby pmUser2000 » Sat May 30, 2009 3:20 am

hi virnie,
meanwhile somebody can help us in the translation of this post, I want to share with all this post of PM installation in XP ( in spanish ) I hope this will be useful .

http://alumnos.dcc.uchile.cl/~eallende/ ... ows_XP.pdf

secretfriend
Posts: 10
Joined: Thu Jul 09, 2009 3:54 am

Re: Windows XAMPP installation [TRANSLATION]

Unread postby secretfriend » Wed Jul 15, 2009 4:31 am

I'll try to translate.

Beginning:

He had processmaker installed under windows with xampp. It it was running.
The folder was at "C:\processmaker\workflow".
The pmos.conf is shown and some error-logs.

When he tried to access some point of the menu he got an error.

And when he tried to open the "input documents" section he got another error.


Additionnal information:

The used package was : pmos-1.2-2261.tar.gz
There was no firewall installed and he was testing on a so-called intranet server.



Why not use the windows installer version?

Because he had an existing xamp installation and he didn't want to risk losing anything out of it.



A solution that is suggested is to make some versions run in parallel but the user 'reamon' claims that he aldready tried this and that this didn't work very well.


Finally he'll try to reinstall it all under another, clean, computer/server.
Andy

pmUser2000
Site Admin
Posts: 460
Joined: Fri Aug 31, 2007 6:48 pm

Re: Windows XAMPP installation

Unread postby pmUser2000 » Fri Jul 17, 2009 11:40 am

thanks secretfriend

WhatUp
Posts: 2
Joined: Tue Jan 22, 2013 11:02 am

Re: Windows XAMPP installation

Unread postby WhatUp » Tue Jan 22, 2013 11:05 am

fernando wrote:hi virnie,
meanwhile somebody can help us in the translation of this post, I want to share with all this post of PM installation in XP ( in spanish ) I hope this will be useful .

http://alumnos.dcc.uchile.cl/~eallende/ ... ows_XP.pdf

In what do you want it to be translated? I could help you! I love translations ;)


Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 1 guest