Page 1 of 1

APP NUMBER no sigue la secuencia

Posted: Mon Dec 03, 2018 1:26 pm
by vcaceres
buenas tardes amigos, por favor puedo saber cual puede ser el motivo en el cual ciertos numeros de casos no aparecen en processmaker, es decir estoy en el 901 y de ahi se salto al 915 por ejemplo, he revisado en application, appcacheview, pero no hay rastro.

por favor alguna idea.

Muchas gracias.,

Re: APP NUMBER no sigue la secuencia

Posted: Mon Dec 03, 2018 8:29 pm
by amosbatto
Cada vez que un nuevo caso es creado, 1 es agregado al numero del caso en el campo APP_SEQUENCE.ID en la base de datos. No importa si has borrado el caso despues, el numero del caso ya es utilizado.

Re: APP NUMBER no sigue la secuencia

Posted: Tue Dec 04, 2018 10:01 am
by vcaceres
Gracias Amosbatto, ok entiendo, pero porque ciertos numeros no se encuentran en la tabla application o app_cache_view, por lo general asi se encuentren en draft saben encontrarse ahi., por ejemplo haciendo un select de los app_number podemos observar lo siguiente :
Casos desapar.png
Casos desapar.png (18.09 KiB) Viewed 1568 times

Re: APP NUMBER no sigue la secuencia

Posted: Tue Dec 04, 2018 11:24 pm
by amosbatto
Tus usuarios probablemente han creado los casos 989 - 1005, pero han usado el menu Action > Delete para quitarlos, que borra las filas de los casos en las tablas APPLICATION, APP_DELEGATION y APP_CACHE_VIEW.

Re: APP NUMBER no sigue la secuencia

Posted: Mon Dec 10, 2018 11:04 am
by vcaceres
Perfecto amigo muchas gracias.