Discussion about the internationalization and localization of ProcessMaker

Moderators: ArturoRobles, ArturoRobles

By zeiscas
I was trying the spanish.po file translation but the special characters like "í, ó, ú,..." does not appear correct. On the other hand, the message box signaling task transfer does not show the task name (only the user)!?

Thank you for your help.
User avatar
By liliana
Good Afternoon,

If you are using the special characters on lables I suggest you to use this syntaxis
Code: Select all
 <![CDATA[ Ejecución de un Proceso ]]>
on this way you are notgoing to have problems with special characters in spanish.

For the other issue which version of ProcessMaker are you using?

Best Regards.
By zeiscas
Hi Liliana,

Thank you very much. But, I figured out some " strange" issues!
I imported the spanish.po file and I can see the labels (well some are still in english) in spanish. But then I queried the 'Translation' table and I only have the english strings! Then, I searched the spanish.po file I can´t find the labels (for instance) 'Read' and 'Unread' but these ones appear, wrong, in spanish - 'Leídos' and 'No leídos' appear like 'LeÃdos' and 'No leÃdos'!!!
Where are these labels?

The other issue happened on 2.0.34. On 2.0.35 seems to be Ok.

Best regards
liliana wrote:Well we have some issues on version 2.0.34 that's why we strongly recommend using the latest version, most of the issues like labels were solved of this version

Thanks for solving this issue in upgraded version.
By zeiscas
Hi Liliana, good morning,

This issue is not solved on version 2.0.35! The special characters are not appearing ok. On the other hand, I can't find the strings on the .po file to correct them with your sugestion ([CDATA]...).

Please, can you help me!
Thank you.
The CDATA trick is for labels in DynaForms. It doesn't work in .po translation files. OK, first of all, did you alter the PO file or did you download it and import it directly into ProcessMaker? If you opened the PO file, you might have changed the character encoding. Second, what happens if you change the character encoding with your web browser? In Firefox, go to: View > Character Encoding > Unicode (UTF-8)
By zeiscas
Hi Amos,
Thanks for your reply.
To confirm, I just downloaded again the .po file and uploaded it; same result. I also have confirmed that the browser has UTF-8. I tried to change to other encodes and some of the menus had change but the ones with problems had not!
My problem is related with the "main" labels of PM (menus). How can I access them?
I attached an image for you to see what's happen.

PM main menu.
PM_sp.jpg (24.24 KiB) Viewed 5452 times
With versions 2.0.35 and 2.0.36 in Spanish, I can't reproduce this problem with clients running Chrome, FireFox and IE in Windows XP and clients running Firefox 8.0 and Chromium in Debian. However, all are using ProcessMaker installed on a Ubuntu 10.04 server. What OS do you have ProcessMaker installed in and what web browser are you using?
please double check your apache setup is using UTF8,
in fact apache and mysql needs to be in UTF8, but in PM we are forcing to use a UTF8 connection. so another option to check are your tables, which collation are you using? seems you are using latin-collation or similar instead the UTF8 collation.

Hello, I'm trying to make a HTML page in which a[…]

IOS PUSH Notification

Latest Mobileios.pem already get its SSL cert expi[…]

Enabling SQL Server in Windows

Nice. https://360digitmg.com/india/ethical-hacking[…]

PM 3.5.0 supports MySQL 5.7.X configurations with […]