ProcessMaker news, events, releases, and updates

Moderator: amosbatto

#784602
This Hotfix includes 5 new features, 18 improvements and 271 solved bugs.

Requirements:

ProcessMaker v. 3.0.1
PHP 5.4 (indispensable)

To take a look at the complete list of new features, improvements and bug fixes; please take a look at the following document:
https://docs.google.com/document/d/12cM ... mBbqIg/pub

Known Issues

- Because of the changes in backend for the suggest control, the SQL queries related to its execution MUST NOT have the LIMIT sentence.
- The restore and backup of a workspace can only be made in the same platform (Windows -> Windows, Linux -> Linux) because the names of the tables of MySQL in Windows are not case sensitive which may make ProcessMaker have problems.
- In the Web Edition, mobile controls only show the information retrieved from the application.
- The ProcessMaker engine does not support the execution of a sub-process configured as "asynchronous" after a parallel gateway.

- If the design of the process includes a section as the figure above, set the asynchronous process (es) and the rest of the activities in a sequential order instead of using a parallel gateway (http://wiki.processmaker.com/index.php/ ... el_Gateway).
- PM – 4538: In the Community Edition the Email Intermediate event does not send the configured email.
- PM – 4551: The flow Start Event > Intermediate Event is not supported by the ProcessMaker engine even if the cron does create the case; it is not shown in the Inbox. This happens because users assigned to the case are obtained from the first task of the process.

Recommendations

- From version 3.0.1.6 of ProcessMaker, it is MANDATORY to install it using PHP version 5.4 in linux systems and version 5.4 or 5.5 in Windows systems.
- The directory where ProcessMaker is installed should have write permissions.
- ProcessMaker does not support MySQL strict mode.
- The gateway - intermediate event execution support is available for new processes. For processes that had this design before v.3.0.1.7 the configuration must be saved again to work properly (http://wiki.processmaker.com/index.php/ ... ate_Events).

Languages

English (Default core language)

Hi, I have a problem with iteration of subprocess[…]

I am creating an application using the Process Mak[…]

Hi guys, I recently landed into processmaker commu[…]

Thank you Ricardo, I am upgrading it to 3.4.11 Is[…]