ProcessMaker news, events, releases, and updates

Moderator: amosbatto

User avatar
By amosbatto
#5305
Change Log for ProcessMaker Open Source, release 1-2.2985

***************** New Features *****************
4. Custom notification to next user in workflow
http://bugs.processmaker.com/view.php?id=3495
Minor bug: Create a function:
getCurrentAssignedUsers ( delindex, application, )
which will generally be used after derivation y ought to obtain the majority of its parameters from $_SESSION
carlos 2009-11-05 17:18:35
added the new PM Function PMFgetNextAssignedUsers()

6. Floating toolbar for large process maps
http://bugs.processmaker.com/view.php?id=3568
When you are working in very large process maps, it is very difficult to add routing rules between tasks because you have to scroll up to the routing rules toolbar. It would better to make this toolbar float with the scrolling so that you can use the toolbar when you are lower in the process map.
carlos 2009-11-06 16:43:04
Now the toolbar floats with the scrolling window.

9. Call a change event when the Date Picker inserts a date in DynaForms
http://bugs.processmaker.com/view.php?id=4175
Currently there is no way to know when a date field has changed in a DynaForm, because the change event is never called.
erik 2009-11-19 10:22:00
yes the change event is not available for date field because its own behavior has changed, in fact this event never was available.
amosbatto 2009-11-19 14:00:14
We need a change event to be called when the date is changed with a date picker. Just add the following code to the Date Picker when it changes a date:
if (getField("fieldname").onchange)
getField("fieldname").onchange();
erik 2009-11-26 10:03:53
well, the feature for onchange event into date field was added.

The only restriction is:
* To set the onchange event into node tag property self
i.e.
<xdate type="date" beforedate="0m" afterdate="1y" mask="Y-m-d" required="0" readonly="0" showtime="0" defaultvalue_sel="empty" onchange="myOnChageFunc()">

This because the event must be set when the object is being created, after sets with i.e leimnud.event.add() or document.getElementById('obj_id').onchange=function(){}
will not work.

13. Conditional Show/Hide
http://bugs.processmaker.com/view.php?id=3666
Writing Javascript for conditional Show/Hide is tedious. We need the ability to show/hide fields without having to code javascript.

erik 2009-10-30 08:53:42
I added a checkbox to the left of each field in the Fields Handler to show/hide it.

16. Simplified Formulas and calculations in dynaforms
3746 http://bugs.processmaker.com/view.php?id=3746
Right now for dynaforms to have calculations the XML must be edited. We would like to see the calculations to be performed as part of the behavior section of a text, dollar or percent field.
erik 2009-11-11 17:18:14
This feature is available now for currency, percentage and textbox DynaForm fields.

30. Request for fixed width font in Edit Trigger dialog box and a wider textarea for editing
http://bugs.processmaker.com/view.php?id=3923
It is very inconvenient to edit the PHP code in triggers because the dialog box provides very little space and it does not provide a fixed width font, so it is very hard to distinguish characters like single quotes and see small characters like periods and semicolons, which is very important when programming. 1. Make the textarea where triggers are edited use a fixed width font. 2. Make the dialog box MUCH WIDER. It needs to be big enough so the user can see at least 80 characters wide by 50 characters high in Courier font.
fernando 2009-11-13 09:14:21
we added the next class in style.css, please sure you add this class in your current customized skins: form.formDefault textarea.FormTextPM
{
border: 1px solid #CCC; background: #FFFFFF url(/skins/green/images/input_back.gif) repeat-x; color:#333333; font:normal 9px Courier; overflow:auto;
}
fernando 2009-11-13 09:29:57
please see attached image, this all we can do ( 85x23 in courier font ) Committed revision 2897.
fernando 2009-11-25 10:48:16
which other font is better? background: #FFFFFF url(/skins/green/images/input_back.gif) repeat-x; color:#333333; font:normal 9px Courier;

31. UID numbers in dynaforms are not user friendly
http://bugs.processmaker.com/view.php?id=3943
A suggestion from many clients is that you should take out the UID number from the dynaform list window. Maybe it should be better to put a link where you can find the UID number. Showing up this number straight forward makes the user a bit confused of what it actually means.
fernando 2009-11-12 17:50:35
Added an alert with the dynaform uid, see the picture attached to this bug. Fix committed in revision 2895.

32. Users Cant see the total List Of Processes when they are starting a new task.
http://bugs.processmaker.com/view.php?id=3948
I have this problem when users need to pick a process from the processlist to start a new case. As you can see on that screenshot users cant see the full list and also cant see the scroll bar so people cant understand that there are more processes below the list. There are hundreds of people working so there might be easy to mistaken. For the next versions could you please fix this visual problem . Or any other advice?
fernando 2009-09-25 09:12:28
Hi, The problem is the process title and case title are very large, and the dropdown grows more than the screen. alternative solutions: 1. reduce the process title and task title 2. create a plugin for start cases, 3. do you think if we render a list of starting cases with a radio button in the left, and then you select the process checking the radio button will help to your users?
Best regards
fernando 2009-11-06 18:11:59
Committed revision 2882. render a list of starting cases with a radio button in the left, and then you select the process checking the radio button.

33. Web services function createUser() needs to send back the automatically generated UID for the user
http://bugs.processmaker.com/view.php?id=3950
Currently the createUser() function returns the role of the new user in the message element in the pmResponse object. This doesn't help at all because the role is already known (since it was one of the input parameters). Instead createUser() should return the UID of the new user which was automatically generated in the message element. Also, the input parameter userid should be changed to username, to help clarify what needs to be input.
fernando 2009-09-25 12:05:52
Since release 2740, the createuser methods returns the user GUID, please check with this release and let me know if there are other improvements to do.
amosbatto 2009-09-26 06:24:35
I checked createUser() with version 2740. It now returns the user's UID, so that works. Here are the things that I would like to see changed: 1. The parameter "userId" should be changed to "username", so people don't think that they have to enter an ID number for the user. 2. If it is possible to have optional parameters with WSDL, I would like to see the option to input all the information about the user, such as address, telephone, position, etc.
fernando 2009-09-28 19:23:13
Now, that UID is returned, about these two points:
1. The parameter "userId" should be changed to "username", so people don't think that they have to enter an ID number for the user. I can change it, but this change will be uncompatible with current version 2 of WSDL, really is necesary to change this parameter name?
2. If it is possible to have optional parameters with WSDL, I would like to see the option to input all the information about the user, such as address, telephone, position, etc. yes we can add optional parameters, that should be work, and the backward compatibility should be fine, too. So, what should be the next step? what do you think.
amosbatto 2009-09-29 09:07:50
OK, I will indicate in the wiki that userId is for the username and not for the UID. If we ever create WSDL3, we should change it to username, because in the other functions when we say "id" we are referring to the UID.
fernando 2009-11-06 16:09:38
"OK, I will indicate in the wiki that userId is for the username and not for the UID. If we ever create WSDL3, we should change it to username, because in the other functions when we say "id" we are referring to the UID."
Thanks. no more changes are needed. So this bugs is resolved

36. Simplified Formulas and calculations in dynaforms
Please check the bug: 3960 http://bugs.processmaker.com/view.php?id=3960 Right now for dynaforms to have calculations the XML must be edited. We would like to see the calculations to be performed as part of the behavior section of a text, dollar or percent field.
support 2009-09-25 12:21:21
Fernando, Please prioritize the resolution of this bug, since is a request from HD Suply. Thanks Patty
support 2009-11-12 10:34:27
Erik, Resolves this issue (0004648) erik (reporter) 2009-11-11 17:18 this issue is available now for currency, percentage and text dynafields

38. 693 erik Feature 4199 Bugid : 3957
Bug:3957 Conditional Show/Hide
Please check the bug: 3957 http://bugs.processmaker.com/view.php?id=3957 Writing Javascript for conditional Show/Hide is tedious. We need the ability to show/hide fields without having to code javascript.
support 2009-09-25 12:11:53 Fernando, Please prioritize the resolution of this bug, since is a request from HD Suply. Thanks Patty
erik 2009-11-10 11:37:24 this was implemented such as new feature for the next release

39. Form Field Hints / Tooltips with HTML formatting
http://bugs.processmaker.com/view.php?id=3976
When creating a form field, give the option to include
fernando 2009-11-06 16:26:27 we can add the "hint" option, but only for plain text. There are no plans to add Rich Text Formatted content, because even in the example the hint is plain. please confirm if you agree.
carlos 2009-11-26 08:35:00 now you have a new option with this you can include a message help to form fields. this is in the properties fields (Hints message)

44. Request to add message explaining why web entry page was not created
http://bugs.processmaker.com/view.php?id=4036
Web Entry with the option "PHP Pages with web services" does not work if the task has "Manual Assignment" or "Value Based Assignment". If the user tries to create a web entry for a task which has one of these options, no web entry pages are created and no link is displayed, but the user is not informed why web entry was not created.

ProcessMaker needs to display the message:
-------------------------------------------
Unable to create web entry page.

Web Entry with the option "PHP Pages with Web Services" only works with tasks which have "Cyclical Assignment". Please change the "Assignment Rules" for task "%s" or select the Web Entry option for "Single HTML".

carlos 2009-11-26 08:25:58
when you change the Assignment rules and you choose other value that isn't Cyclical Assignment,now there is a message that says: "Web Entry only works with tasks which have Cyclical Assignment Please change the Assignment Rules"

45. Request for ability to delete web entry and edit existing web entry
http://bugs.processmaker.com/view.php?id=4038
There is no option to edit or delete an existing web entry in ProcessMaker. For instance, what happens if you want to change the username and password for a web entry. There is no way to currently do it. The only way to edit a web entry is to go edit the files in /opt/processmaker/shared/sites/workflow/public/. The only way to delete a web entry is delete those files. It should be possible to edit and delete web entries inside the ProcessMaker interface.
carlos 2009-11-04 14:38:56
fixed added delete link and if you want to edit a web entry you can edit a web entry if you choose the same options for this web entry on New link
patricia 2009-11-26 10:29:16
The option is implemented, but there is something missing. When you click on the "delete" link, a "blank" message box appears, without any text. Please include the following message: "Do you want to delete the Web Entry?" Thanks.

48. Save As New option for Dynaforms
http://bugs.processmaker.com/view.php?id=4031
Please see attached jpg.
support 2009-10-09 17:48:02
Fernando, I find this a great option from HD Supply. Could you please evaluate its implementation? Thanks, Patty
carlos 2009-11-10 15:44:50
added save as option

50. Add empty folders /shared and /compiled to the source code tarball
http://bugs.processmaker.com/view.php?id=4131
To make it easier to install from source code tarball, add the empty folders /shared and /compiled, so people don't have to manually create those folders when manually installing ProcessMaker.
fernando 2009-11-05 16:11:57
done. the tarball will be available in next release (approx. Nov 15th)

65. Request to add a [@#] button to Output Document Editor to insert system and case variables
http://bugs.processmaker.com/view.php?id=4146
It is very difficult to remember variable names. A [@#] button should be added to insert variables in output documents.
gustavo 2009-11-18 16:46:36
It has been added a "@#" button to the output documents editor, now a user have a more accurately and easier way to insert variables into output documents. The button is located on the lower -right section of the editor and when its pressed calls to a list of the available process variables, from there just select the variable an insert it, in the desired place. Fixed in revision: 2909 These fix or feature will be available in the Next release of PM.
gustavo 2009-11-26 19:03:02
Now in the output document editor the variable @# button now its fully compatible with Internet Explorer 6-7-8 and gecko browsers. revision 2936

80. Request to add a [@#] button to Output Document Editor to insert system and case variables
4217 http://bugs.processmaker.com/view.php?id=4217
It is very difficult to remember variable names. A [@#] button should be added to insert variables in output documents.
erik 2009-11-25 16:20:04
which is the problem???
gustavo 2009-11-25 17:18:04
Well seems that it the solution doesn't work entirely for Internet Explorer versions 6-7-8. The insert link, well doesn't insert anything! Another revision will be made to this issue, in order to achieve cross browser compatibility.
gustavo 2009-11-26 19:02:20
Now in the output document editor the variable @# button now its fully compatible with Internet Explorer 6-7-8 and gecko browsers. related to bug 4146. revision 2936

***************** Bugs Fixed ****************
1. Releases have been deleted from the SourceForge Download site
http://bugs.processmaker.com/view.php?id=4174
Many of the ProcessMaker releases have been deleted from the SourceForge Download site at: http://sourceforge.net/projects/process ... _test=var1
People need those releases because they need the patch files to upgrade. Please restore all the versions. People are complaining because they can't find patch files for their version of ProcessMaker.
See: http://forum.processmaker.com/viewtopic.php?f=8t=1533
fernando 2009-11-12 11:24:24
now, old files are showed in this link: http://sourceforge.net/projects/process ... _test=var1

3. Delete a user with pending cases
If deleting a user with pending cases, show a message to either derive (route) his cases or reassign the cases to another user.


5. View Permission allows deletion of input documents
http://bugs.processmaker.com/view.php?id=3566
Hi, I set up view process permissions on input documents for all employees but this has also given them the permission to delete documents? I created a new user group called all_employees and added all the users to it. Then I set process permissions as follows
Status Case: Completed
Group or User: all_employees
Type: Input document
Permission: View
No other permissions have been set. User can open the case, list input documents, view and download them is OK, but they also have the option to Delete the document.
hugo 2009-11-12 14:26:26
This bugs was fixed

10. A user who uploads or generate documents can not see those documents in the “Information” sidebar.
3592 http://bugs.processmaker.com/view.php?id=3592
hugo 2009-11-26 08:01:44
Now the user who has uploaded or generated a file has permission to see this file, even when there are no defined process permissions for the file.

11. 416 erik Major 3939 Bugid : 3615
Bug:3615 Bug when trying to see uploaded document
Please check the bug: 3615 http://bugs.processmaker.com/view.php?id=3615
I had a problem to view an uploaded document. I think this happened because I have deleted a task and put another in the same place. As I had already created cases with the old task, when I tried to view an uploaded document, the code had searched for the old task. Only when i deleted all the registers with the old task in APP_DELEGATION, it started to work well. This must be a problem with the code in cases_Ajax.php to retrieve the document. Or can be a problem of the primary keys of the table APP_DELEGATION. I think this is important to verify.
erik 2009-10-21 12:45:20
this problem was solved for the 2838 release of PMOS.

18. Limits in Expiration Date field for users
http://bugs.processmaker.com/view.php?id=3785

When creating users, the user's Expiration Date can only be set after 2010.
gustavo 2009-11-13 14:33:46
This bug was resolved in a prior release.
gustavo 2009-11-13 14:37:18
Now it is possible when creating users to set the Expiration Date up to 5 years in the future.

19. WebEntry does not work when using input documents
http://bugs.processmaker.com/view.php?id=3781

Hi, When using a WebEntry (PHP) for a dynaform with a input document in it, the webentry page does not process the file. I've tested the following scenarios, always with the same result:
- Process with a dynaform and a input file in it (not associated with input document): NOT WORKING;
- Process with a dynaform and a input file (associated with input document): NOT WORKING;
- Process with a input document only: NOT WORKING;
By the way, in my instalation of ProcessMaker 1.2.2552 (upgraded from 1.2.2467) the page ADMIN->WEB SERVICES, the last webservice listed is UploadFiles but it doesn't work too!
Regards, Joel Frojmowicz.
erik 2009-11-25 15:45:45
solved, upload files -> (with/without) a input documents related implemented by web services into webentry pages works now

21. Error when clicking on column headers for list of triggers in the Steps Of: dialog box, Triggers tab
http://bugs.processmaker.com/view.php?id=3823
I right click on a task in the Process Map, and select Steps from the menu. In the Steps Of: X dialog box, I click on the Triggers tab. Then I click on [+] to see the list of triggers for particular time. If I then click on the column header for the list of triggers, I see the following error:
Notice: Undefined index: action in C:\Program Files\ProcessMaker\apps\processmaker\htdocs\workflow\engine\methods\steps\steps_Ajax.php on line 55

22. gustavo Major 4377 Bug:http://bugs.processmaker.com/view.php?id=3861
I make changes to an unsaved DynaForm and then click on [X] to close the DynaForm. A message box pops up asking:
---------------------
Exit without saving?

  [OK] [Cancel]
---------------------
I click [OK] because I do NOT want to save the changes. The next time I open the DynaForm, I see that my changes have been saved. The user should have the ability to discard changes if he/she wants to.
fernando 2009-11-16 10:26:23
please take a look of this post, there is more information about this issue and related issues. http://forum.processmaker.com/viewtopic.php?t=708
amosbatto 2009-11-16 16:08:00
Fernando, The forum post is about a different issue. I am talking about changes in the DynaForm Builder when I am *altering* a DynaForm, not when I am running a case. If I add a new field to a DynaForm, then I click on [x] to close the DynaForm, the DynaForm is automatically saved, even when I selected [OK] to exit without saving.
gustavo 2009-11-19 17:27:24
Thnx for your advise. This issue is finally solved, now whenever a user tries to discard all unsaved changes by exiting the Dynaform Editor clicking in the [X], well he will be able to do it. The next time a user open the Dynaform Editor only the saved Form will be displayed. Seems that there is was some problem with the temporal form files of PM. This fix will be available in the next release of PM revision # 2917

24. HTML grids don't update
http://bugs.processmaker.com/view.php?id=3918
When modifying the HTML code for grids, the changes from the grids don't update in the grid form.
erik 2009-10-21 13:09:21
Cuando se modifican los templates de los dynaforms manualmente ya no se toma posteriores cambios a los xml, para que estas modificaciones tomen efecto se debe regenerar los templates borrandolos,. estos se volveran a generar cuando cuando se llamen en tiempo de ejecucion.. se recomienda hacer un backup del template modificado manualmente; aplicar los cambios al nuevo template generado luego....

25. XML option savelabel=1 for title objects in DynaForms does not work
http://bugs.processmaker.com/view.php?id=3903
The XML definition for title objects in DynaForms has a savelabel option, but it does to not work. If I have the XML definition: Expense Request When I run a case, no case variable @@ExpenseTitle_label is created.
amosbatto 2009-09-19 23:28:04
The savelabel option appears in the XML code for a lot of fields, but it only works for dropdown boxes. It shouldn't be inserted by default in all those fields if it isn't used.
carlos 2009-11-16 15:14:32
Now the savelabel option appears only for drowndown boxes, and if we have Expense Request the variable @@ExpenseTitle_label is not created.
Erik 2009-12-02 09:09
this works fine with normal dropdowns, but not with dropdown with a sql query related (referred to bug 0003903), this will be scheduled for futures releases

26. Change error message for required field to use field label instead of field name
http://bugs.processmaker.com/view.php?id=3904
If a required field is blank, the error message to inform the user says:
"The field <FIELD_NAME> is required!"
It should be:
"The field <FIELD_LABEL> is required!"

Only if the field label is blank, should the message show the field name, because most users when running a case, won't know what is the field name.
carlos 2009-11-13 13:12:44
If you don't put a name to your field and it is required the message of required now is with its label

27. When I use reassign by user and I choose an user, the program reassign to other person
http://bugs.processmaker.com/view.php?id=3917
I´m trying to use reassign by user, but the program reassign wrongly. I choose a person, the program send to another. By the way, with the normal reassignment the program sends to the right person, but shows a different name in the feedback alert.

29. When I use reassign by user and I choose an user, the program reassign to another person
http://bugs.processmaker.com/view.php?id=3916
erik 2009-10-21 13:21:28
This problem was fixed in the current release 2838
graziele 2009-10-29 14:04:45
http://forum.processmaker.com/viewtopic.php?f=7&t=1310
erik 2009-11-19 09:54:00
Well, the problem that you mensions has been replicated and it was fixed right now. This issue will be available in the release 11 (next from release 2865) I want to thank you for the support that you give us, that do that every day is a better ProcessMaker.
Best regards. Processmkaer Developers Team


34. Can not use Date field as primary key in PM Tables--Error when editing record
http://bugs.processmaker.com/view.php?id=4067
If I create a PM Table with a date field as the primary key, I can create new records in the table, but if I try to edit an existing record, I see the following Error:
Notice: Undefined index: DATEASPRIMARY in /opt/processmaker/workflow/engine/classes/model/AdditionalTables.php on line 977 Fatal error: Uncaught exception 'Exception' with message 'The registry cannot be updated! Error, row cannot updated' in /opt/processmaker/workflow/engine/classes/model/AdditionalTables.php:1005 Stack trace: #0 /opt/processmaker/workflow/engine/methods/additionalTables/additionalTablesUpdateData.php(30): AdditionalTables->updateDataInTable('7064460994ad67f...', Array) #1 /opt/processmaker/workflow/public_html/sysGeneric.php(530): require_once('/opt/processmak...') #2 {main} thrown in /opt/processmaker/workflow/engine/classes/model/AdditionalTables.php on line 1005

42. Error in FOR SUPERVISOR Tab
http://bugs.processmaker.com/view.php?id=4018
See screen shot. it is for all cases in realestate workspace error: Fatal error: Uncaught exception 'Exception' with message 'The row '5578945844a7999c62fe662036393286' in table Dynaform doesn't exists!' in /opt/processmaker/workflow/engine/classes/model/Dynaform.php:217 Stack trace: #0 /opt/processmaker/workflow/engine/templates/cases/cases_toRevise.php(71): Dynaform->Load('5578945844a7999...') #1 /opt/processmaker/gulliver/system/class.g.php(753): include('/opt/processmak...') #2 /opt/processmaker/gulliver/system/class.publisher.php(620): G->LoadTemplate('cases/cases_toR...') #3 /opt/processmaker/gulliver/system/class.publisher.php(87): Publisher->RenderContent0(0) #4 /opt/processmaker/workflow/engine/methods/cases/cases_Ajax.php(341): Publisher->AddContent('view', 'cases/cases_toR...') #5 /opt/processmaker/workflow/public_html/sysGeneric.php(504): require_once('/opt/processmak...') #6 {main} thrown in /opt/processmaker/workflow/engine/classes/model/Dynaform.php on line 217
carlos 2009-11-06 09:09:31
now is removed all about this dynaform

43. Subtitles next to each other in the Fields Handler causes layout issues
http://bugs.processmaker.com/view.php?id=4025
I have to have Subtitles right next to each other in the form. They have
support 2009-10-08 18:26:47
Erik, Please validate the use of HTML in subtitle fields, in order that the Field Handler doesn't have this issue. For testing, please find attached the process example provided by HD Supply. Thanks.
erik 2009-10-23 08:54:27
solved

47. Using the next release (2741+), ProcessMaker can't deal with PM Tables with tabs '\t'
http://bugs.processmaker.com/view.php?id=4047
I have the csv file containing:
------------------------
ID; Description
123;\tWhat's up fool!
------------------------
where \t is a tab.
After importing the csv file and I go to edit the record 123, I only see in the Description field: [What] Here is the HTML which is generated for the field:
erik 2009-10-22 11:11:47
this problem was fixed on the current realease 2838

52. Duplication of tasks on parallel fork before join
http://bugs.processmaker.com/view.php?id=4082
Two instances of the SAME task where fork is joined are created in certain cases. Depends on sequence of executed tasks. Test case is described on forum http://forum.processmaker.com/viewtopic.php?f=7t=1430 Process example is there. Reproduced on fresh install from http://sourceforge.net/projects/process ... e/download and also on http://live.processmaker.com/sysprocesi
sasamad2004 2009-10-16 03:32:34
I have marked it as blocking since I cannot continue in my work.
sasamad2004 2009-10-22 03:34:13
Same happens on pmos-patch-2741-2838.tar.gz
sasamad2004 2009-10-25 10:19:17
Has anybody looked at this?
Bladiebla 2009-11-18 02:27:03
I'm having the same problems, it's blocking many of our processes which I want to implement. Could somebody give priority to this? Thank you :)
fernando 2009-11-18 15:48:07
we are starting to check this issue..
carlos 2009-11-20 18:01:41
thanks, now this is resolved
sasamad2004 2009-11-26 05:08:19
How can I apply the patch? Is there one?

54. Unable to select date within the next 30 days when pausing a Case.
http://bugs.processmaker.com/view.php?id=4075
Open a case and go to CASES > ACTIONS and click on Pause in the sidebar. In the dialog box, the date picker does not allow any date within the next 30 days. For instance, if today is 15 Oct 2009, then I can only choose a date between 15 Nov 2009 and 14 October 2011. This needs to be changed because most people who pause a case want to unpause the the case within the next 30 days.
erik 2009-11-04 10:42:04
this problem was solved right now and will be available on the next release... (current release 2865)

56. Change text from: Logged on $x to Using workspace: $x

http://bugs.processmaker.com/view.php?id=4128
Now processmaker shows this information in the upper right hand corner: ----------------- Administrator (admin) | Options | Logout Logged on WORKFLOW - October 27, 2009 ----------------- The information in my opinion is confusing, because it looks like I am logged on as user WORKFLOW. We should eliminate the confusion by not using the words Logged on for the workspace. I suggest: ----------------- Administrator (admin) | Options | Logout Using workspace: workflow - October 27, 2009 ----------------- I also suggest that the workspace name should be case sensitive and not be automatically converted to uppercase. That way if a user creates a workspace called AccountingDept, it will retain the proper capitalization.
hugo 2009-11-16 08:41:36 Fixed. Label changed to Using workspace: and showing the name of the workspace without uppercase it

57. When a parrallel fork inside of a parallel fork, workflow does not wait for all paths to finish executing at parallel join.
http://bugs.processmaker.com/view.php?id=4138
The outer parallel join doesn't work correctly when there is an inner parallel fork inside of an outer parallel fork. See the forum for discussion of this problem: http://forum.processmaker.com/viewtopic.php?f=7t=1430 To try it out, download the sample process in the forum.
sasamad2004 2009-10-29 05:15:39 I have updated relationship information, because I have already submitted bug report.
sasamad2004 2009-11-04 03:08:23 Hi guys! This bug is a showstopper for some processes. I think it is more than minor and is becoming quite urgent. Any info? I have increased severity and priority.
sasamad2004 2009-11-04 03:11:22 Hi fernando! Can you check this one?
sasamad2004 2009-11-13 04:28:50 Please help with this one!
carlos 2009-11-20 17:58:56 thanks, now this is resolved
sasamad2004 2009-11-21 06:56:54 What do I have to do on my installation?
sasamad2004 2009-11-23 08:42:12 How can I patch my installation?

58. Error in masks for date fields
http://bugs.processmaker.com/view.php?id=4097
When changing the mask for a date field to “%m-%d-%Y”, the values of the field are not derivated.
carlos 2009-11-04 07:45:27
fixed

59. Trigger after step throws an error
http://bugs.processmaker.com/view.php?id=4136
While executing a process case in debug mode, triggers which are after step always throws this error (see jpg file joined).
erik 2009-11-19 10:05:52
this problem was fixed from the release 2565

60. TextArea width
http://bugs.processmaker.com/view.php?id=4129
The textarea field in the grid dynaform has the property cols being used as clos, then the field doesn't change the width.
erik 2009-11-06 17:20:48
fixed

61. LDAP imports fullname into USR_FIRSTNAME
http://bugs.processmaker.com/view.php?id=4134 $aData['USR_FIRSTNAME'] = $aUser['sFullname']; $aData['USR_LASTNAME'] = '';
fernando 2009-11-05 16:38:10
Hi, you are right when saying this is works because the $aUser['sFullname'] have the full name, what should be the field for the last name and the first name in Active Directory and Open Ldap?
scowse 2009-11-05 17:08:22
In AD "givenname"=firstname and "sn"=lastname I do not know OpenLDAP fields

62. Clean / convert garbage characters from ISO_LOCATION and ISO_SUBDIVISION tables in workspace DBs
http://bugs.processmaker.com/view.php?id=4164
Clean / convert garbage characters from ISO_LOCATION and ISO_SUBDIVISION tables in workspace DBs See attached examples from following queries: SELECT * FROM ISO_LOCATION I WHERE I.`IL_NAME` like '%
gustavo 2009-11-16 14:26:12
The ISO_LOCATION and ISO_SUBDIVISION tables has been cleaned. Both now show the correct data for the field names IL_NAME and IS_NAME for those tables respectively. For example, the location: Gh?zi?b?d is now corrected to Ghaziabad In order to achieve a solution, some changes needed to be made to the Database and the file insert.sql. These changes correspond to the revision 2903. This issue will be fixed in the next release of PM.

63.Some issues with dates
http://bugs.processmaker.com/view.php?id=4120
When I use a date field, the value becomes empty after going through some forms where this date field was in view mode. This also happens in grids. Also, when I tried to use the javascript function hideRowById() to hide a date field in view mode, a javascript error occurs, so I leave it in edit mode and set readonly='1' and this works.
edwin 2009-10-28 12:44:07 In normal dynaforms the date becomes empty when it has a different mask as the standard. But in grids the dates becomes empty when 1. Grid mode="edit" -- user enters the date 2. Grid mode="view" -- date is ok 3. Grid mode="edit" -- date becomes empty. Please review this!. Thanks
carlos 2009-11-04 07:45:00 fixed

64. ProcessMaker DOC Output Documents do not work with OpenOffice
http://bugs.processmaker.com/view.php?id=4144
Output documents in DOC format are not compatible with OpenOffice, which is very important because OpenOffice has roughly 10% of the Office Suite market and is the only office suite available for users of Linux, which controls roughly 3% of the desktop market for computers. I have the output document with the following definition: This is a test of case @=APPLICATION with index @%INDEX running on @#SYS_SYS, using lang @@SYS_LANG When I run a case, I see the following output document in OpenOffice: MIME-Version: 1.0 Content-Type: multipart/related; boundary===boundary; type=text/html; --==boundary Content-Type: text/html; This is a test of case @=APPLICATION with index 1 running on workflow, using lang en --==boundary--
gustavo 2009-11-20 16:16:29
Now those headers are removed from the presentation of the .doc file. These fix made a more cleaner generated output document. These fix will be available in the next release of PM revision # 2929

66. Web forms should adopt the css from the style in their url
http://bugs.processmaker.com/view.php?id=4159
Web forms should adopt the css from the style in their url, ie: http://processmakerdev.hdsupply.net/sys ... Picker.php Date_Picker.php should have the style hds.css Currently no matter what the style it is always green.css.
hugo 2009-11-26 07:59:23
Now also the Blank template takes the style of the current Skin. (This is used in web entries and in some POpups)

67. Error when a case is paused..
http://bugs.processmaker.com/view.php?id=4162
When a case is paused, this should be to pass to the paused cases, but this case disappears from the TODO list but it isn't in the paused cases list,.. this case appears in the all cases list.. and it's with To Do status..... :O
erik 2009-11-23 16:41:53
this problem usually accurs when the case has been corrupted. but a the actions woks fine from current release (2865)

68. Long names in DynaForm fields
http://bugs.processmaker.com/view.php?id=4166
When I need to input a long name in a DynaForm field, the name is limited to a certain number of characters.
I need that this field be larger to permit longer names.
erik 2009-11-10 14:26:01 The current max size of a DynaForm textbox is 128 characters. With that length
You can insert a long name, such as: "12345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901111234567890123456789012344" or perhaps you are refering to another thing. We need your feedback please
edgardo 2009-11-11 11:28:59
For a DynaForm it is not necessary to have more
than 128 but we have a project (Daytop) whose form names are very large
and these are cut when we try to enter them. Could you please solve this? Could you extend them to more than
128 characters.
erik 2009-11-12 14:41:32
Now the max size is 256 characters. I hope that is enough.

69. The setup mail for pmos envimonment view is not showing correctly
http://bugs.processmaker.com/view.php?id=4168
The setup mail for pmos envimonment view is not showing correctly
erik 2009-11-06 09:17:43
solved
support 2009-11-25 18:10:19
The way to reproduce the error: 1. ADMIN->EMAIL-> AN CHECK Enable Email Notifications 2. configure the smtp parameters and click in test button 3. a windows shows the test email configuration, in that window the interface is no showing correctly (borders outside and title in bad positions) rechecked, ok

70. Error in Paused Cases List
http://bugs.processmaker.com/view.php?id=4196
In this list are appearing cases that are not really in pause (they are reassigned in this case)
rhemme 2009-11-23 09:54:05
This is a reproducible bug--here are the steps:
1) Create a process with two tasks (Task 1, Task 2) connected sequentially.
2) Start a case in the new process at Task 1. Complete the first step, and assign it to any user (which we will call "User1") for Task 2.
3) As an administrator or as User1, reassign the task to another user. 4) Logged in as User1, look at the Cases | Paused view. The case that has been reassigned will display on the list. As far as I can tell, it remains there for the user permanently. If the Unpause command is activated, a bug similar to "double delegation" occurs and another record is added for the case in the app_delegation. The DEL_THREAD_STATUS for this record remains at OPEN, causing listing problems for the case in the future (such as disappearing from all ProcessMaker views when completed).

76.Problem with double forking and joining
http://bugs.processmaker.com/view.php?id=4184
See: http://images.cannonfodder.nl/processma ... e_fork.png or attached image. When all the GO! tasks are completed END is suddenly activated. All the LEAVE! tasks are joined on END together with the final two GO! tasks. END should not activate until _ALL_ LEAVE! and GO! tasks are completed. Attached is also an export of the process.
carlos 2009-11-20 18:17:28
thanks, now this is resolved

77. Uploaded documents not working in web entry
http://bugs.processmaker.com/view.php?id=4204
Uploaded documents not working in web entry. If I create a case within PM it uploads properly and is attached to the case. I have attached my process for your review.
patricia 2009-11-20 08:52:39
Fernando, This is the approved SOW from HD Supply and you find the original requirement at: http://bugs.processmaker.com/view.php?id=4155 I guess you need more information for implementing this new feature, so please let us know your questions and also when you think this feature will be implemented. Thanks, Patty --- On Tue, 11/17/09, John Paul wrote: From: John Paul Subject: SOW HDSupply To: [email protected], [email protected] Date: Tuesday, November 17, 2009, 2:40 PM Patty: Adjunto lo indicado en la referencia. Thanks, John Paul Martin-Rojas International Business Development & Sales Manager Colosa Inc. +1.617.340.3377 ext 124 http://www.processmaker.com Open Source Workflow & BPM
erik 2009-11-25 15:44:50
solved, upload files -> (with/without) a input documents related implemented by web services into webentry pages already works now

78. Multiples files related to inputs documents into a dynaform is not working
http://bugs.processmaker.com/view.php?id=4211
Multiples files related to inputs documents into a dynaform is not working.. operational error in the processmaker CORE.
erik 2009-11-24 14:27:52
fixed

79. Email Addresses in the format: "Amos Batto" get changed to: "> "Amos Batto"
http://bugs.processmaker.com/view.php?id=4215
Bug 3984 has been fixed so email addresses in Send Message Events allow the format: Amos Batto but now the email address gets changed to: >Amos Batto To reproduce define a new Send Message Event and then add the email address and click Save. Then click on the Action link to reopen the dialog box and the email address will have been changed to: >Amos Batto In the dialog box to define the Send To, CC and BCC lists, the only types of emails accepted are in the format [email protected]. It is impossible to define an email recipient such as 'Amos Batto '.
fernando 2009-11-25 11:26:53
which is the problem, it is not resolved or the release doesn't fulfills the requirement?
erik 2009-11-30 08:39
the bug was fixed for CC and BCC fields right now.




************** Bugs Closed *****************
2. Upload multiple files with only one select file dialog:
http://bugs.processmaker.com/view.php?id=3216
It would be possible to upload multiple files with only one select file dialog:
1. Click Upload files button on dynaform
2. Select multiple files (with shift and ctrl keys)
3. Upload selected files and attach them as input documents
Thanks for review.
erik 2009-10-20 16:53:23
you can create some input file fields and link its input property to some input documents that was created before,.. I attach .pm example process


7. Could a button be added on fields list of the Dynaform editor to move fields to the top?
http://bugs.processmaker.com/view.php?id=3572
I want to add a field to an existing dynaform. Normally, the new one is added to the bottom of the form. When I want to place it on top, I must click the up button and move up one by one. If there are many fields, it's will be a hard work. Could a button be added named “move to top” or “move to bottom”?
carlos 2009-11-04 11:23:09
this problem was fixed with fields handler feature available on the current release


8. Filling Grid Text fields from MySQL
http://bugs.processmaker.com/view.php?id=3576
Hi, In my DynaForm, I have one grid with two text fields. I wrote a trigger to fill these from a MySQL database. My trigger is as follows:
@@reportTestGrid = executeQuery(select id,model_id from printers_model_id_info, 01ba526e7fb6ac91ff7babd331fe1e23);
I did not get any errors. Even the Grid is dynamically expanding as per the number of rows in the table (i.e., in printers_model_id_info). But, surprisingly, nothing is getting displayed on the text fields. I attached the grid output in this post. I have only one line code in my trigger (as above). Please let me know if I need to add any further code to my trigger for the proper display of on the text fields. I have searched the forum but can't find the solution. Could you please help me to solve this problem?
Thanks in advance.
Regards,
carlos 2009-11-23 11:50:09
hi,
maybe your mistake is in the name of your xml nodes of the grid
those should be like the names of your fields of your table
for instance, you can see it here

/***************/
/*YOUR DATABASE*/
/***************/
SAMPLEK
__________________
|SMP_ID| SMP_COLOR |
------------------ |
|1 | 'red'
|2 | 'green'
|3 | 'black'
|4 | 'pink'
-------------------
/**************/
/*YOUR TRIGGER*/
/**************/
@#GLLASAMPLE=executeQuery('SELECT SMP_ID, SMP_COLOR FROM SAMPLEK', rp);
/****************/
/*YOUR GRID CODE*/
/****************/
<?xml version="1.0" encoding="UTF-8"?>
<dynaForm type="grid" name="8431634894b010cdcb5ced3037299346/3894264354b01579bc2b2f4033263882" width="500" enabletemplate="0" mode="edit">
<SMP_ID type="text" maxlength="64" validate="Int" required="0" readonly="0" size="15" mode="edit">
  <en>ID</en>
</SMP_ID>
<SMP_COLOR type="text" maxlength="64" validate="Real" required="0" readonly="0" size="15" mode="edit">
  <en>COLOR</en>
</SMP_COLOR>
</dynaForm>

12. Can't modify task properties
http://bugs.processmaker.com/view.php?id=3658
Hi, I'm new to Process Maker but I think I found a serious bug. I can open the task properties form with a right-click, but I can't finish the edition of properties because:
- save button does nothing (I can only cancel)
- tabs other than definition are not usable
This happens in Firefox 3.11 and IE 6.
Please fix it, thank you
carlos 2009-11-23 15:19:06
hi, I tried it in IE 6 and firefox 3.0.15 and I can't replicate this bug maybe it was solved in the new releases


14.Attempt to create a new WebEntry can not be completed.
http://bugs.processmaker.com/view.php?id=3724
Steps taken; * In the PROCESS tab, right click on Design Area and select Web Entry, * Click New on Web Entry window, * Select Web Entry properties, [tried every combination, with Grid, Normal froms, HTML or PHP Output], * Click on Generate Web Entry Page, * There is no content in the coming window [refer to attached image], nothing happens.
erkang 2009-09-11 17:18:33
This bug persists in the PMOS v1.2-2552.
erkang 2009-09-11 17:20:36
And yes the permission of the directory it is supposed to be writing is 777 (/opt/processmaker/shared/sites//public//)
No files are created in this directory.
erik 2009-10-21 13:14:08
Well the issue could be happening because your shared directory is not accesible for processmker,. please do: 1. make sure that the group and user apache is owner of ./path_installed/processmaker/shared 2. grant the permissions to 755 at shared directory.
erkang 2009-10-21 15:06:20
1. Yes, the entire tree is set to be owned by the apache user.
2. Yes, the permissions are granted to 755 at the shared directory. I remember amosbatto mentioning the possibility of a configuration issue with Apache. Would you like to have a look at the apache conf? As I have stated in the post below, I ran out of options in installing and testing in different environments like Fedora, CentOS, Ubuntu and even lately on Windows Server, besides FreeBSD. http://forum.processmaker.com/viewtopic ... 36c2#p4419 The only version I can make WebEntry form created is the Vista, which has no server value for me. I would be glad if you can forward me to a known working RPM, Amazon AMI or specific versions with more strict configuration information.
erkang 2009-10-21 16:18:39
Tested browsers; FF 3.5, IE 7.0, Google Chrome 3.0, Opera 10 and Safari Fresh install of PMOS stable release v. 1.2.-2740 on the following operating systems; *Fedora, *CentOS, *Ubuntu, *Windows Server
erik 2009-11-05 18:09:14
Hi erkang, we want to help you but unfortunately, we were unable to reproduce your error. We have a lot of server running with Centos, debian, ubuntu, etc..., (windows too, but not such as server) and nobody has the problem that you mention. So this bug entry will be closed because we do not consider this to be a bug of pmos. So, for more answers look in the forum please.
Atte: Processmaker Developers Team

15. Upload Files
http://bugs.processmaker.com/view.php?id=3743
Would like the ability to have uploaded files default to a specific storage area outside of the web server such as a NAS appliance.
support 2009-10-02 16:57:08
You could configure this using nfs. The folder "shared/sites/{your_workspace}/" contains the documents from "your_workspace", so you could link this folder using nfs to another folder in a NAS server. Please let me know if this meets your requirement. If not, please explain a little bit more what you need.

17. Add hidden fields to the grids
http://bugs.processmaker.com/view.php?id=3763
fernando 2009-11-13 11:25:01
Feature added in previous versions, no change was required

20. Bottom of Upload button cut off in Process Files Manager
http://bugs.processmaker.com/view.php?id=3855
I right click on Process Map, select Process Files Manager, then click public directory, then click Upload Files link to get to the dialog box to upload files. This dialog box has a blank space at the bottom. The Upload button is cut off at the bottom. See screenshot.
fernando 2009-11-13 11:14:53
no change required, previous versions have improved this feature

23. Request for a web services function downloadFiles()
Bug:http://bugs.processmaker.com/view.php?id=3872
Please check the bug: 3872 In addition to the uploadFiles() function, web services ought to offer a downloadFiles() function to get files from the public and html_templates directories.
fernando 2009-09-07 18:17:46
...I think the webdav feature should be enough to get this kind of files. the upload method in the webservices (coming soon) should allow users to upload "input documents" to a specific case, the complementary method to the upload function should be the download of output documents, but this is possible using the appropiate url in a browser session. but anyway, let us think a little more about these feature.
fernando 2009-11-13 09:35:29
The webdav feature should be enough to get files related for the Process Definition, for files related to cases, the webservices allow to download them.

28. Error Defining Case Tracker Information
http://bugs.processmaker.com/view.php?id=3915
I'm creating to my enterprise throw this sample available at http://wiki.processmaker.com/index.php/Case_Tracker and the images that appear to show are different from mine. I'm using the last version of ProcessMaker. The page that appear doesn't contain the buttons to assign new Objects as well as at the case Tracker - Properties Page. This make a crush on this feature. Please see the images attached.(ZIP file with 2 images) Is this a problem of this new version? Thanks
fernando 2009-11-13 10:11:29
Hi, we tried to reproduce the screen you sent us, but with last version of PM they don't showed. Seems the problem was because you updated your PM, and you need to refresh the browser cache. I hope this issue is no longer valid, as I think it was only a cache issue. Anyway let us know if the issue continues.
lmccpedro 2009-11-13 10:54:10
Thanks for the answer. In my new version it's everything ok. Maybe it was a problem in cache in that time.

35. Sending another notification message (warning) when a case in todo OVERDUED/DELAYED.
http://bugs.processmaker.com/view.php?id=4032
I think it is important to send another warning message to users who have tasks overdued/delayed cause if they are too busy they might forget that they have tasks waiting.Especially people like managers who really has not much time. Is it possible to design such a system on PM ?
erik 2009-10-30 10:44:52
Well, we will have your request, but you must to appreciate that processmaker is a workflow (BPM) with a generic model like a CMS, ERP, etc,. the particulars behavior are not referred in this context.. but we will see what we can do,.. thank's for your interest in PMOS
amosbatto 2009-11-25 10:20:07
You can use an event to send a message when the task is due.

37. Upload Files
http://bugs.processmaker.com/view.php?id=3961
Would like the ability to have uploaded files default to a specific storage area outside of the web server such as a nas appliance.
support 2009-09-25 12:22:55 Fernando, Please prioritize the resolution of this bug, since is a request from HD Suply. Thanks Patty
fernando 2009-09-30 12:11:30 Since the shared/sites/{workspace} is the folder where all files about the workspace are stored, this folder should be linked using nfs to another folder in other server or NAS server.
fernando 2009-09-30 12:13:43 based in current request description no change is needed. Is only a setup issue. Please clarify the requirement if this is not the case.
support 2009-10-19 11:42:21 We haven't heard from HD-Supply regarding this issue in 3 weeks, and we believe it is resolved. For this reason, we are closing the issue ticket. In case that HD-Supply requires more attention in this issue, we'll inform you. Patricia Cabero
carlos 2009-11-06 16:32:02 We haven't heard from HD-Supply regarding this issue in 3 weeks, and we believe it is resolved. For this reason, we are closing the issue ticket. In case that HD-Supply requires more attention in this issue, we'll inform you. Patricia Cabero


41. Loss of labels
http://bugs.processmaker.com/view.php?id=3993
Segun el informe enviado por la UMSA, se presentaron problemas en el servidor de desarrollo despues de la instalaci
julio 2009-10-05 19:05:39 Primero, el archivo en español que se encuentra en el wiki está mal, no se debe descargar ni usar el mismo, para obtener el último archivo válido para español se lo debe de solicitar a soporte. Segundo el problema de las etiquetas no pudo ser replicado (se intento subir un archivo .po inválido).
carlos 2009-11-10 16:01:00 this bug maybe was resolved in the last versions
amosbatto 2009-11-25 11:18:49 The Spanish translation in the Wiki and SourceForge works in 1.2-29XX—I just tried it.

46. Field handler error
http://bugs.processmaker.com/view.php?id=4034
In the field handler when you click on a field to edit I get the attached alert/error.


erik 2009-10-30 08:56:07
sorry, we can not to reproduce your problem,... the fields handler works fine in Firefox 3.x +0, IE 7, 8 and safari

49. The link for web entry does not automatically appear after creating PHP Pages with web services
http://bugs.processmaker.com/view.php?id=4035
I right click on process map and choose Web Entry. Then click New to create a new web entry. I select PHP Pages with web services and enter information, then click Generate Web Entry Page. The link for the new web entry does not appear in the list in the Web Entry dialog box. To see the link, I have to close the Web Entry dialog box, then right click on the process map and select Web Entry from the menu again and then I can see the link. When the user clicks Generate Web Entry Page, the list in the Web Entry dialog box should get automatically updated to display the new link.
erik 2009-10-20 11:21:38
I can not to reproduce that problem,.. please give me more issue details.... before try again in the new release please...
amosbatto 2009-10-29 11:06:17
I just tried it in version 1.2-2838 and it works correctly now. The link now appears automatically.

51. Only the first page of dashboards works. Subsequent pages show no records and no navigation buttons
http://bugs.processmaker.com/view.php?id=4069
If I go to the DASHBOARD menu, I see several dashboards with multiple pages. If I click on the > button to go to the second page, I see no records in the second page and the navigation buttons |< < > >| at the bottom of the dashboard disappear, so there is no way to return to the first page. See the attached screen shot.
erik 2009-10-22 17:31:35
well this happens when you browser session has expired for processmaker, plase try it on again, make sure that you session is active, when your session is activew the pagining on dashbords list is working correctly... please tell us your feedback....
amosbatto 2009-10-27 09:43:39
You are right. My session must have expired, because now it works. Still, there should be some way to detect when inside a form that the session has expired and take the user to the login screen.

53. Grid dynaform not working correctly in IE8
http://bugs.processmaker.com/view.php?id=4074
I created a grid dynaform with a date and a text area. I'm using this to make a pseudo comment system for a process. It works correctly in FireFox but not in IE8. I have attached the process.
support 2009-10-15 12:09:07 Please correct this issue, it was reported for HD Supply. Attached a process example for testing. Thanks.
erik 2009-10-20 09:09:35 sorry I can not to reproduce this problem,.. please try again over new release...
erik 2009-11-26 08:18:34 I've test with your process example, and works fine in IE 8.0.7100

55. Triggers fail to fire after submittting a form
http://bugs.processmaker.com/view.php?id=4078
In Internet Explorer 6, triggers fail to fire after Submitting the Form.
erik 2009-11-10 17:29:48
well try it on again please,... from release 2865... I've done some tests for IE 6, and all my triggers (after and before) worked fine!

71. Calender of date field stays on the screen in the Dynaform editor using Firefox.
http://bugs.processmaker.com/view.php?id=4177
When using the Dynaform editor:
1. Add a date field.
2. The field name is visible, the input box and calender pictogram are not visible.
3. When (left) clicking on the area where the input box is supposed to be a calender fields appears, without the frame.
4. When switching to the other tabs of the Dynaform editor or when scrolling the calender stays visible at the same location.
Problems:
1. Inputbox of datefield should be visible
2. Calender frame should appear with close button.
renaissance 2009-11-11 03:13:41
Hello, i am having same issue on my system too, I tried to erase totally and re-install PM many times but always had same problem. I also tried to refresh/delete my browsers cache and files under compiled directory , it still doesnt work, thats why i cant use v2865 . Hope developers will find a solution about that sooner or later .
erik 2009-11-11 17:49:08
I this issue happens because the date picker has been changed internally,.. please try this: 1. delete the content into dyrectory //pmos_installation_path/compiled/*
2. delete your cache browser
3. In other hand,.. for a new installation make sure that all directories and sub directories were deleted. Your problem is that the css styles and some images weren't loaded correctly
renaissance 2009-11-13 01:04:56
I tried many times to delete PM from my system with all of its dir⊂dir. But everytime i install, same problem persists. And also even i use windows installer i have to create Compiled and Shared directory Manually. Is it going to be like that on upcoming versions of PM too ? Thanx in advance.
martijnburger 2009-11-14 06:49:14
I deleted the contents of the compiled directory and cleared my browser cache but the problem still persists. I tried a vanilla installation of processmaker. With the vanilla installation the problem is not there. The version in which the problem persists was originally 2740 on which a applied the patches pmos-patch-2741-2838 and pmos-patch-2838-2865. I didn't have time to reproduce this complete procedure.
renaissance 2009-11-17 01:07:55
Yes exactly after 2740 problems occuring about date field and also when i install 2865 directly also i get this error. This is quite annoying ,its the only reason that i cant upgrade my production environment even there are many new features that i d like to use in new versions. Hope from the next version on( i think its at the end of november) developers will fix it somehow.
erik 2009-11-25 09:58:42
Hi, the principal problem that I can see, is that the calendar css styles is missing that's why the problem exists. please could you tell me if you're usign your own skin, just because the skin must be updated with the same changes in CSS (styles.css) from the default skin 'green'.
renaissance 2009-11-27 00:55:51
Nope actually I'm using default skin, and another thing is that even i made a fresh install of v2865 on my testing env.many times. I'm still getting this date picker's famous callback function error. This is the reason that i don't upgrade my production environment's version. Hope you guys will give us good news about that on next release. Thanks in Advance...


72. Problem with last plugin of Knowledge Tree
http://bugs.processmaker.com/view.php?id=4176
Problem with the last version of ProcessMaker and the last plugin of KnowledgeTree. I tested for 2 times, and after install the plugin fot KT in this last version of processMaker is giving the error shouwn in Additional Information. You already detected and its corrected somewhere, or its a new bug?
Thanks Lu
hugo 2009-11-11 15:23:54
Hello Luis, Please could you tell me what steps you followed at time of install/update KT Plugin? The problem that you report is a missing field in the table that has added for this last version and that field may be included at update or install time.
Regards,
lmccpedro 2009-11-12 05:29:45
Hi Hugo, for the update of the KT Plugin i just download the file "knowledgeTree-1.23.tar" on the processmaker sourceforge web site. Then with admin login, went to Administration menu->PlugIns->Import and then i selected that file. Seems some problem, just on this New version of Plugin, in this New version of ProcessMaker.
hugo 2009-11-12 09:29:03
Hi Luis, For some reason the Update Tables function is not working in your case. I have retested the Plugin updating a prev version and it works. If you have access to your database and have some knowledge about running queries in mysql I can send you the queries to fix your issue.
lmccpedro 2009-11-12 12:44:14
Hello, for some unknown reason it doesnt works in my version. Hugo, if you could send me this queries i can execute with no problem. I will apreciate a lot if you could send me that. Thanks a lot
hugo 2009-11-12 13:12:19
here you are... At your main database wf_WORKSPACE execute this... ALTER TABLE `KT_DOCUMENT` ADD `DOC_TYPE` VARCHAR( 4 ) NOT NULL AFTER `DOC_UID`; ALTER TABLE `KT_DOCUMENT` ADD `DOC_PMTYPE` VARCHAR( 10 ) NOT NULL DEFAULT 'OUTPUT' AFTER `DOC_TYPE`; ALTER TABLE `KT_DOCUMENT` DROP PRIMARY KEY ,ADD PRIMARY KEY ( `DOC_UID` , `DOC_TYPE` ) Good luck. Tell me if it works
lmccpedro 2009-11-13 07:09:14
Hello Hugo, thanks for the help. That script was the main key to resolve some problem that could be relationed also, that i report in the following link: - http://bugs.processmaker.com/view.php?id=4178 [^] About the script no problem. It worked. There's no more error's. Thanks Again


73. JavaScript method onaddrow() example does not work
http://bugs.processmaker.com/view.php?id=4173
In the wiki page about JavaScript, there is an example: var oAux = getObject('MyGrid'); oAux.onaddrow = function(iRow) { //actions in js form dynaform alert('answer'); }; See: http://wiki.processmaker.com/index.php/ ... l_examples I tried this code and nothing is displayed and no JavaScript errors are displayed. I tried the following code to try and debug: alert(typeof oAux); // works alert(var_dump(oAux)); //works var sOut=''; for (var property in oAux) { sOut += property + : + oAux[property] + nn; } alert(sOut); The last part returns a lot of methods and properties, but onaddrow is not included.
hugo 2009-11-12 15:17:11
Hello, Sorry that example is deprecated. Could you try this: grid_GRIDNAME.onaddrow = function (iRow) { alert(iRow); } where GRIDNAME is the name of your Grid Field and you prefix it with the word grid_

74. Problem creating a Case of a Process with Input documents
http://bugs.processmaker.com/view.php?id=4178
Hi, i have a problem when creating a case from a process with an input document. This happen creating a folder in KT. It appear and i cannot explain why, because everything was working good in this process. why such thing can start to happen?
hugo 2009-11-12 15:02:19
This kind of error usually happens when the KT objetc has not instantiated correctly. It could happen if the KT plugin was not configured correctly and/or when there are problems communicating with the KT server
lmccpedro 2009-11-13 07:13:15
It was possible to resolve this problem after the upgrade to the new version 1.2-2865 of ProcessMaker and KnowledgeTree Plugin Update to 1.23. And also after run the script available in the following issue: http://bugs.processmaker.com/view.php?id=4176

75. Can't unpause a case
http://bugs.processmaker.com/view.php?id=4182
When we try to unpause a case it displays the confirmation dialog and then nothing... the case stays paused.
erik 2009-11-23 16:41:05
this problem usually accurs when the case has been corrupted. but a the action works fine from current release (2865)

Hi, I have a problem with iteration of subprocess[…]

I am creating an application using the Process Mak[…]

Hi guys, I recently landed into processmaker commu[…]

Thank you Ricardo, I am upgrading it to 3.4.11 Is[…]