ProcessMaker news, events, releases, and updates

Moderator: amosbatto

User avatar
By amosbatto
#4778
ProcessMaker is pleased to announce release 1.2-2865 which fixes a number of critical bugs. The Date Picker now works in web-entry forms. With this release, triggers now fire correctly after derivation of cases and the trigger debugger works again. Several of the JavaScript problems in Internet Explorer 8 have been resolved.

To download version 1.2-2865, please visit the ProcessMaker SourceForge website at http://sourceforge.net/projects/processmaker/files

--------------------------------------------------------------------------------------
Changelog for release 1.2-2865

1. 335 carlos Minor 3997 Bugid : 3528
Bug:3528 possible bug in Grids and report tables
Please check the bug: 3528 http://bugs.processmaker.com/view.php?id=3528 Is this a bug? please check it. http://forum.processmaker.com/viewtopic.php?t=529 Has anyone seen behavious where the new link on the grid does nothing. I have two cloned processes (exported and reimported) but the grid dynaform has been recreated. On one of the processes the grid works fine on the other it just does nothing. Very strange. In the same way if I create report tables for one of the processes it's fine for the other it throws exceptions. The copied process may be a red herring....or it may be the problem. Any ideas?
carlos 2009-10-19 17:56:08 It seems already fixed in the latest versions, and couldn't replicate the error
carlos 2009-10-19 18:05:56 It seems already fixed in the latest versions, and couldn't replicate the error.

2. 367 carlos Minor 4018 Bugid : 3560
Bug:3560 Invisible tyracks
Please check the bug: 3560 http://bugs.processmaker.com/view.php?id=3560 On the graphical view of the processes, lines connecting the different processes sometimes disapear. When moving a process a few milimeters, the line will be there again. The connection is always there, only the visible line disapear. It is quite anoying, as you have to move all processes to be sure no lines are hidden.
carlos 2009-10-19 19:15:02 I tried to replicate it , but I couldn't. It seems already fixed in the last version.

3. 380 erik Major 4005 Bugid : 3567
Bug:3567 Name of Tasks being erased
Please check the bug: 3567 http://bugs.processmaker.com/view.php?id=3567 Por favor, entren al http://live.processmaker.com/sysrobinson/ y vean 2 tareas abajo que dicen tarea 9 y tarea 10. Si tratas de cambiar el nombre a estas tareas y despues sales y entras al proceso, vas a ver que no se esta grabando el nombre de estas 2 tareas.
erik 2009-10-20 17:13:03 This problem was solved for the current release of PMOS

4. 415 erik Major 3948 Bugid : 3613
Bug:3613 design problem, the process of uploading templates
Please check the bug: 3613 http://bugs.processmaker.com/view.php?id=3613 design problem, the process of uploading templates. ...(click)Process Files Manager, Mail template (click)Upload Files, design upload.
erik 2009-10-06 13:06:42 that problem was fixed changing all upload interface to other improved interface

5. 442 erik Major 4016 Bugid : 3648
Bug:3648 Crash when create or edit an existing field on a dynaform
Please check the bug: 3648 http://bugs.processmaker.com/view.php?id=3648 Whenever I try to add or edit an existing field on a dynaform, it crashed. The first case is when I am creating a new process and a new form, when adding a new field to the form, it gives an error below. The second case is when I am importing an existing process, and try to edit a field on a dynaform, it gives the same error.
erik 2009-10-06 16:26:46 this bug was fixed right now

6. 469 erik Major 4007 Bugid : 3677
Bug:3677 To Reassign displays Multiple Users in the Reassign field
Please check the bug: 3677 http://bugs.processmaker.com/view.php?id=3677 1. Go to the Credit Card Application pm file. 2. Create a new user, named 'ho', and put it in the Employee group 3. Assign the Employee group to the first task ( Application Task) 4. Login as 'admin', new a case, select 'Credit Card Application' as the Process. 5. When you are at the firs task (Title Of: ), click on the Actions Link. 6. Click Reassign as shown in the image. 7. Select ho as the person to reassign to. 8. Now, got to the To Reassigned page (/cases/cases_List?l=to_reassign). 9. Note that there are multiple cases appear in the table area
nsoonhui 2009-07-20 11:23:20 Note that there are two users with regard to the same case.
nsoonhui 2009-07-20 12:14:23 My suspicion is that the filter condition in workflow/engine/classes.class.case.php for the 'to_reassign' case is not correct. Here's the code snippet that handles the case for reassignment: case 'to_reassign': $c->add($c->getNewCriterion(ApplicationPeer::APP_STATUS, 'TO_DO')->addOr($c->getNewCriterion(ApplicationPeer::APP_STATUS, 'DRAFT'))); $c->addDescendingOrderByColumn(ApplicationPeer::APP_NUMBER); $xmlfile = $filesList[7]; break; Maybe you should add another condition that takes the element with biggest DEL_Index in app_delegation table.
erik 2009-10-20 11:43:45 This problem was solved in 2838 release

7. 521 erik Minor 3897 Bugid : 3740
Bug:3740 CUANDO SE LLAMA MAL A LA FUNCIONES DE PMFUNCTION
Please check the bug: 3740 http://bugs.processmaker.com/view.php?id=3740 --------------------------------- capturar el fatal error --------------------------------- VALIDACION, CUANDO SE LLAMA MAL A LA FUNCIONES DE PMFUNCTION FUNCION NO EXISTE O ESTA MAL ESCRITA, ejemplo PMFgetLabelOption() ? MFgetLabelOption(), sale este error: Fatal error: Call to undefined function MFgetLabelOption() in /opt/processmaker/workflow/engine/classes/class.pmScript.php(139) : eval()'d code on line 2
fernando 2009-08-19 06:52:01 duplicado de 3740

8. 619 carlos Minor 4323 Bugid : 3878
Bug:3878 cancelled task appears in the paused tab.
Please check the bug: 3878 http://bugs.processmaker.com/view.php?id=3878 When someone or a supervisor cancels a process, it is not going to the cancel tab, instead of this this case appears into the paused tab with the option to unpaused the case. Please review this issue. Thanks
carlos 2009-10-26 12:47:08 fixed change the status in the query

9. 641 carlos Minor 4166 Bugid : 3900
Bug:3900 Masks for textboxes in DynaForms don't work when text is pasted, rather than typed
Please check the bug: 3900 http://bugs.processmaker.com/view.php?id=3900 If I have the mask ###, I can paste with CTRL+V any text into the textbox, such as adfae or q34n435q4 The javascript code to validate masks only runs with onkeypress events and doesn't run with onchange events.
carlos 2009-10-20 12:21:30 fixed

10. 710 erik Minor 4206 Bugid : 3980
Bug:3980 (Current Task User) listed twice by default in Send to box for Send Message Event
Please check the bug: 3980 http://bugs.processmaker.com/view.php?id=3980 When creating a Send Message event, the (Current Task User) appears twice by default in the Send To box. It should only appear once.

11. 733 erik Feature 4321 Bugid : 4007
Bug:4007 Email Template Editor window to expand
Please check the bug: 4007 http://bugs.processmaker.com/view.php?id=4007 Please allow the html Email Template Editor window to expand so you don
erik 2009-10-20 11:15:05 is ready!

12. 739 carlos Major 4320 Bugid : 4017
Bug:4017 Setting up a new work space error
Please check the bug: 4017 http://bugs.processmaker.com/view.php?id=4017 I was setting up a new work space and got the following fatal error. See attached screen.
fernando 2009-10-15 13:24:49 basically there are some restrictions in the workspace long. Please try to short the workspace name. Meanwhile we are going to reproduce this issue.
carlos 2009-10-23 17:45:40 fixed limit the length of the DB name

13. 746 erik Major 4319 Bugid : 4026
Bug:4026 Process lock up when adding a routing rule
Please check the bug: 4026 http://bugs.processmaker.com/view.php?id=4026 When adding a routing rule the pop up will not go away. I can not close the window and continue creating the process. This causes me to have to close my browser and log in again. There is also a javascript error present. See attached screens.
support 2009-10-08 18:52:38 In version 1.2-2740, it is not possible to add Routing Rules from the Routing Rules option. Clicking on new in IE7 appears the error showed in the attached document and the browser is blocked. In IE8 the line for the new routing rule is added, but it is not possible to edit nothing. The issue has been reported by HD, so please review it. Thanks.
erik 2009-10-21 16:16:35 fixed

14. 764 carlos Minor 4313 Bugid : 4049
Bug:4049 In the new version (2741+), the list of records of a PM Table should show spaces in the fields
Please check the bug: 4049 http://bugs.processmaker.com/view.php?id=4049 If I have a field in a PM Table with whitespace. For instance: Dear Client,ntThank you. It gets displayed as: [Dear Client, Thank You] The HTML is: Dear Client, Thank you. It should have tags around it to show the spaces: Dear Client, Thank you.
carlos 2009-10-21 15:22:20 fixed now PM TABLES shows spaces in the fields

15. 747 carlos Minor 4315 Bugid : 4027
Bug:4027 Use better average sign in Grid Forms
Please check the bug: 4027 http://bugs.processmaker.com/view.php?id=4027 The average sign used in grid forms when function=avg is hard to read. Change it from:
carlos 2009-10-22 12:15:10 fixed

16. 759 erik Minor 4308 Bugid : 4043
Bug:4043 Make fields when editing data in PM Tables wider, because hard to read
Please check the bug: 4043 http://bugs.processmaker.com/view.php?id=4043 When editing data in a record in a PM Table, the fields are too narrow and you can't see all the data in the field. The problem is that the size of the input fields is set to half of the maxlength of the field. The size should be the same size as the maxlength in my opinion, unless the length is over 55. Here is the HTML definition for one of the PM Table fields:
erik 2009-10-22 17:10:20 fixed

17. 760 erik Minor 4307 Bugid : 4044
Bug:4044 Hard to view data in PM Tables because the column widths are set too narrow
Please check the bug: 4044 http://bugs.processmaker.com/view.php?id=4044 When looking at a list of records in a PM table, the width of the columns is set to 100, which is too narrow in my opinion when you have a large fields. All fields regardless of their max length, are set to 100. ProcessMaker should make some adjustment of field width based on the max length of the field and the number of fields. Use code something like: $columnWidth = $maxTableWidth / $numberFields; if ($fieldMaxWidth > $columnWidth) $columnWidth = $fieldMaxWidth;
erik 2009-10-19 18:04:17 solved

18. 761 carlos Minor 4311 Bugid : 4045
Bug:4045 Add a Cancel button when editing PM Table record
Please check the bug: 4045 http://bugs.processmaker.com/view.php?id=4045 When editing a record in a PM Table, there is only a button to Save Changes, but there is no button or link to return to the list of records without saving the changes. There needs to be a Cancel button or a Back to table link, so that the changes in the record won't be saved.
carlos 2009-10-19 15:41:48 fixed
carlos 2009-10-19 15:43:30 resolved

19. 777 erik Minor 4306 Bugid : 4062
Bug:4062 (version 2741+) Label for first task in process disappears when save a dynaform with Save Continue
Please check the bug: 4062 http://bugs.processmaker.com/view.php?id=4062 I do the following: 1. Create a new Process. 2. Add a Task, which has the default name Task 1. 3. Create a new DynaForm. 4. Add a text field to the DynaForm. 5. Go to the Properties tab and select Save Continue for Next Step Link property. Then click Apply. 6. Then save DynaForm and close the DynaForm Editor. 7. When I return to the process map, the label for Task 1 has disappeared. This happened three times in a row. If there are multiple tasks in the process, only the first task in the process looses its label.
erik 2009-10-22 11:13:59 this problem was fixed for the next release

20. 796 carlos Minor 4296 Bugid : 4083
Bug:4083 Add Due Date and Position to the userInfo() function.
Please check the bug: 4083 http://bugs.processmaker.com/view.php?id=4083 userInfo() does not return the Due Date and Position about a user. Currently have to look this data in USERS.USR_DUE_DATE and USERS.USR_POSITION. See: http://forum.processmaker.com/viewtopic.php?f=7t=1432
carlos 2009-10-20 16:38:26 fixed add position and duedate in function userInfo()

21. 794 carlos Major 4297 Bugid : 4081
Bug:4081 Reassign by USER does not work properly.
Please check the bug: 4081 http://bugs.processmaker.com/view.php?id=4081 Reassign by user feature doesnt work properly on my system, even thought i pick the user to reassign case it always reassign randomly. There is more , after reassignment 'Sent by'field is changing too.
carlos 2009-10-22 18:28:07 I tried and it's working well
renaissance 2009-10-27 11:32:21 Today I ve applied the 2838 patch and problem still persists. I choose the one to reassign case but when i press reassign , it sends case to someone else randomly.

22. 805 erik Minor 4326 Bugid : 4095
Bug:4095 objeto calendar no aparece
Please check the bug: 4095 http://bugs.processmaker.com/view.php?id=4095 El componente calendar no aparece en los plugins de reportes de correspondencia, se hace click sobre el espacio vacio donde deberian estar los calendarios y aparecen los calenderios emergentes pero sin formato ni CSS. Esto sucede cuando se utiliza el SKIN que ellos crearon que se llama UMSA, favor a
erik 2009-10-19 16:20:25 nothing to do

Hello, If you are using a version of ProcessMak[…]

I really appreciate the work you did. I got to kno[…]

cam on

hello

Subprocess iteration problem

cam on